2019年7月5日(金)にShopらん一部の環境において検索できない、サービスにアクセスできない障害が発生いたしました。現在は復旧しております。
■現象
以下の時間帯において、お知らせ・書庫などの検索が動作しない、サービスにアクセスできない問題が発生いたしました。
- 2019年7月5日(金)17:00頃:Shopらんで検索ができない問題が発生
- 2019年7月5日(金)17:39 - 18:00:Shopらんが表示できない障害が発生
- 2019年7月5日(金)18:00 -: サービス復旧、一部データが検索できない状態が継続
- 2019年7月6日(土)5:00 - : 検索復旧
■原因
2019年7月4日(木)に実施しました検索インデックスのメンテナンスにおいて、作業手順に不備があり検索インデックスを保持しているファイルストレージのクラスタが正しく動作していませんでした。
2019年7月5日(金)17:00ごろ、クラスタの切り替わりイベントが発生したことで、検索インデックスが参照できない状態となり、アプリケーションサーバーの検索動作がブロックし、サービス停止に至りました。
■対応
2019年7月6日(土)1:00-3:00(JST)に緊急メンテナンスを実施し検索インデックスのクラスタ修復を実施し問題は解消しました。
今後メンテナンス作業の不備を起こさないよう、作業手順、動作検証作業を改善いたします。
本サービスをご利用の皆様には度々ご迷惑をおかけし申し訳ございませんでした。